Apple iOS + L3 roaming, wakeup from sleep

  • 1
  • Question
  • Updated 4 years ago
  • Answered
I just setup a demo environment at my house with the demokit + BR100.

The network is divided between 3 physical buildings of which 2 are connected with cat-cabling and 1 is using Mesh. Since I'm using the demokit, which includes a BR200 wireless model I'm forced to have a separete L3 network behind the BR200.

Now, the separate L3 subnet is located in my 2nd building (basically garage) and when I drive back home my iOS devices immediately connect there. I move inside the house and the devices roam perfectly to the AP's in the house with GRE-tunneling.

The problem comes if I'm say working outside and the devices connect to the BR200 and then go to sleep. Maybe I'll wakeup the device the next day.. the device will by default still have it's IP from the separate subnet but will now be connected to AP's inside the house AND the GRE tunnel will be long gone. It takes forever for the iOS device to understand that it needs to renew it's DHCP loan in order to get the new IP and network to start working. Naturally the workaround is to manually tell it to renew it's IP but still, that's a pain..

Any working solutions for this? Since the BR200 is the acting DHCP-server, should I just lower the lease times to something like 2 hours?

Remember, I'm just playing around with the kit here so this isn't production critical and client "mass" is tiny.. but say you had this in a "all iPad school" or similar where there would be loads of clients moving between subnets and perhaps devices left to sleep over night.. just read somewhere that they're firing up couple of such "Steve Jobs schools" in Netherlands or Belgium..

//Juha
Photo of Juha Lindström

Juha Lindström

  • 8 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Juha,
The easiest solution, as you suspected, is just to lower the DHCP lease duration.
Photo of Peter Mears

Peter Mears

  • 14 Posts
  • 6 Reply Likes
Juha did this solve your issue ? was it really the lease time?
Photo of Gary Smith

Gary Smith, Official Rep

  • 299 Posts
  • 61 Reply Likes
Hi Juha,

Can you verify the following setting please?


If you still have the default (0), you may want to change this value.

Help description;
"Enable Dynamic Tunneling for Layer 3 Roaming: Select to create a tunnel policy for Layer 3 roaming. This enables hive members in different subnets to build tunnels back to portals in the subnet where a roaming client first formed an association and received its IP address. After the client roams to another hive member in a different subnet, that device can tunnel the client's traffic back to the first subnet so that the client can continue using its IP address and not experience any interruption to its existing sessions.

Unroaming Threshold: The unroaming feature allows a device to disassociate wireless clients that have roamed to it from a different subnet (Layer 3 roaming) and have been idle for a specified length of time. When the clients reassociate, they receive an IP address in their new subnet so that their traffic no longer has to be tunneled back to a portal in their original subnet.

Interval: The interval defines how often a device polls for traffic statistics. The default polling interval is 60 seconds. You can change it to another value between 10 and 600 seconds.

Number of packets per minute: The minimum number of packets per minute (to and from a wireless client) defines the amount of traffic required to continue tunneling the client's traffic back to its original subnet. The minimum number of packets per minute can be from 0-2,147,483,647. The value "0" disables the unroaming feature."

Let me know if this helps or if you have already found a solution.

Kind Regards,
Gary Smith
Photo of Juha Lindstrom

Juha Lindstrom

  • 13 Posts
  • 1 Reply Like
Hi all

Sorry for not getting back to this sooner, but I was on a summer vacation for the past 3 weeks.

As for this particular problem, unfortunately dhcp didn't fix it. And to further the pain, I'm seeing the same things now even without the L3 part. So even within the range of 1 single AP, pretty soon after iOS has gone to sleep the connection stops working. When you wake it up, you need to re-connect for it to start working. I'm also seeing this behavior now at our office with 2 AP350's. And for sure there is no L3 subnetting at our small office. But there are some 32 rogue ssid's visible constantly.

Also I'm noticing that while say surfing the web the "connection level indicator" on the iOS & MacOS is varying quite a lot. Since it's mostly happening in areas that have reach to both of the AP's. So I'm wondering maybe I should adjust the roaming threshold to high, in case it's just jumping between AP's? Or maybe it's the 32 rogue ssid's causing channel switching?

I think we've only seen this after upgrading to 6.1 where I turned the app control etc new features on. So one thing might be to try and disable some of those and see what happens.

I'll try and play around a bit and see what happens. Report back here when I have some more info on things.

//Juha
Photo of Gary Smith

Gary Smith, Official Rep

  • 299 Posts
  • 61 Reply Likes
Hi Juha,

Did you reach a resolution with this issue in the end?

Kind Regards,
Gary Smith
Photo of Juha Lindstrom

Juha Lindstrom

  • 13 Posts
  • 1 Reply Like
Unfortunately no. Never found any proper common nominator for this and since then my setup has changes. I don't have the BR200 in my network anymore, so no L3 roamings.

But I'm also experiencing that in a limited manner in mu current L2 setup as well. At times the client traffic just grinds to a halt. That gets immediately resolved when I disable and re-enable wifi in client device. And it's iOS only thing, so could very well be something Apple..

Also I have a pretty dense setup of ap's and I haven't messed around with tx power settings at the ap's, so that could also be one culprit. Shooting both 2.4 & 5 with auto power settings and clients basically hearing all the radios at the house. So they might in theory join with any of the ap's and then get sticky with that, until a reset is given at the client end.

I'll play around some more with settings and try to do a proper channel plan and lower max tx power to something like 14 to make sure the connection doesn't get asymmetric. Possibly also disable dfs range at 5ghz.

//Juha
Photo of Juha Lindstrom

Juha Lindstrom

  • 13 Posts
  • 1 Reply Like
Oh, at the office things have been running really smooth ever since I downgraded ap's to 5.1r5 there. It's rock solid.

But I'll continue testing with 6.1r3 at home lab.

//Juha
Photo of J. Goodnough

J. Goodnough, Champ

  • 266 Posts
  • 32 Reply Likes
are there any recommended settings for unroaming packet/minute values, or rules of thumb that might be handy?