AP250 stuck on orange LED, hard reset not working

  • 2
  • Question
  • Updated 12 months ago
Ap250 has dropped off network, boots to orange, tried various other working POE and switch locations.
no ethernet so no SSH

The console shows through to boot kernel stage

loading file system then starts network eth 0 and eth 1

Register snif device then console hangs on pci enabling device 0001 0002

tried reset button but unable to reset regardless of how long you hold down switch

console boot press key to skip works but apparently the password is not given out

why does hard reset not work, watching console while reset proves no changes are happening, no reboot is triggered

desperately need this AP and RMA takes so long reluctant to send away any other suggestions

Photo of Kevin Whelan

Kevin Whelan

  • 53 Posts
  • 2 Reply Likes

Posted 1 year ago

  • 2
Photo of Jason Zhou

Jason Zhou

  • 18 Posts
  • 13 Reply Likes
Hi, Kevin, Could you please post the boot-up log? You can always contact our support team and they can help replace the firmware if it was not a hardware issue.  Thank you.
Photo of Kevin Whelan

Kevin Whelan

  • 53 Posts
  • 2 Reply Likes


U-Boot 2012.10 (Nov 01 2016 - 04:53:25)

I2C:   ready
Wait.
Done.
DEV ID= 0000cf12
REV ID= 00000000
SKU ID = 0
OTP status: eca00018
MEMC 0 DDR speed = 800MHz
Log: ddr40_phy_init.c: Configuring DDR Controller PLLs
Log: offset = 0x18010800
Log: VCO_FREQ is 1600 which is greater than 1Ghz.
Log: DDR Phy PLL polling for lock
Log: DDR Phy PLL locked.
Log: ddr40_phy_init::DDR PHY step size calibration complete.
Log: ddr40_phy_init:: Virtual VttSetup onm CONNECT=0x01CF7FFF, OVERRIDE=0x00077FFF
Log: ddr40_phy_init:: Virtual Vtt Enabled
Log: DDR Controller PLL Configuration Complete
PHY register dump after DDR PHY init
PHY register dump after mode register write
DRAM:  512 MiB
WARNING: Caches not enabled
GPIO Init ... Done
Power Input Detection: POE AT, Drive GPIO17(USB 5V enable) success
NAND:   NAND_FLASH_DEVICE_ID_ADDR = 18028194
Done that
(ONFI),  S34ML04G2, blocks per lun: 1000 lun count: 1
128 KiB blocks, 2 KiB pages, 16B OOB, 8-bit
NAND:   chipsize
total 0 bad blocks,LIST:
now the up level will see a good flash chip no bad block which size is 20000000
before nvram partition, there are 0 bad blocks
512 MiB
Using default environment

In:    serial
Out:   serial
Err:   serial
Unlocking L2 Cache ...Done
arm_clk=1000MHz, axi_clk=500MHz, apb_clk=250MHz, arm_periph_clk=500MHz
Net:   Registering eth
Broadcom BCM IPROC Ethernet driver 0.1
Using GMAC1 (0x18025000)
et0: ethHw_chipAttach: Chip ID: 0xcf12; phyaddr: 0x1e
bcm_robo_attach: devid: 0x53012
bcmiproc_eth-0
MAC address is c413:e23b:8ec0

NVRAM_MAGIC found at offset 700000
nvram_init: ret 1
Reset TPM chip...
Hit any key to stop autoboot:  0
Hit any key to interrupt boot from flash:  0

Loading kernel from device 0: nand0 (offset 0x800000) ... done
Loading rootfs from device 0: nand0 (offset 0x1600000) ... done
## Booting kernel from Legacy Image at 01005000 ...
   Image Name:   Linux-2.6.36
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2548476 Bytes = 2.4 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
## Loading init Ramdisk from Legacy Image at 02005000 ...
   Image Name:   uboot initramfs rootfs
   Image Type:   ARM Linux RAMDisk Image (uncompressed)
   Data Size:    29970432 Bytes = 28.6 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
Power off two PHY...
   Loading Kernel Image ... OK
OK
boot_prep_linux commandline: root=/dev/ram console=ttyS0,9600 ramdisk_size=70000 cache-sram-size=0x10000

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
...board_fixup
board_fixup: mem=512MiB
board_map_io
board_init_irq
board_init_timer
board_init
Mounting local file systems...
UBI device number 0, total 3256 LEBs (413433856 bytes, 394.3 MiB), available 123 LEBs (15618048 bytes, 14.9 MiB), LEB size 126976 bytes (124.0 KiB)
set attenuator GPIO 7b0d00->7b4d40
et_module_init: et_txq_thresh set to 0xce4
et_module_init: et_rxlazy_timeout set to 0x3e8
et_module_init: et_rxlazy_framecnt set to 0x20
et_module_init: et_rxlazy_dyn_thresh set to 0
register snif device on interface eth0.
eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 10.10.69.74_e5.0.9.1 (r629731)
register snif device on interface eth1.
eth1: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 10.10.69.74_e5.0.9.1 (r629731)
PCI: Enabling device 0001:01:00.0 (0140 -> 0142)
PCI: Enabling device 0002:02:00.0 (0140 -> 0142)

Photo of Jason Zhou

Jason Zhou

  • 18 Posts
  • 13 Reply Likes
Hi, Kevin,
 
Looks like the AP got stuck in bringing up the Wi-Fi driver, it could be a software issue or radio chip issue. Sorry, I can't give more information about that, but I suggest you to open a support ticket, that's usually the fastest way to get this type of issue resolved, Aerohive support team can replace the firmware for you, If that's not working, We can try some other debugging methods and determine whether it's a hardware issue or not and whether you have to RMA the unit.

Thanks
Photo of Collin

Collin

  • 4 Posts
  • 0 Reply Likes
I have had the same issue on several AP250's that we ordered a few months ago. I think I've had 4 so far out of an install of 120. I called AH and they are RMA'ing the units. Seems like maybe there's something up with the AP250 units that were manufactured around that time. Hopefully this failure rate doesn't continue to hold because I have 15 more installs of similar size and RMA's 60 units doesn't sound fun.