AP250 - Random dropped connections for all clients on AP.

  • 2
  • Question
  • Updated 12 months ago
We're seeing further issues with our 250 estate. Sporadically, all clients connected to an AP lose connectivity and fall offline for a few minutes before springing back. I thought it was channel overlap but we're now running in 40MHZ channels instead of the default 80( I think this was causing us issues as well)  so i'm not convinced it's interference as the other end of the floor running the same profile don't see the issues. I ran a spectrum analysis and it all looked fairly good.

The only log i got was the below which seems to point to an issue but i am unsure how to interpret it:
2017-05-03 10:03:48 info    kernel: [wifi]: 1 wlc_txbf_set_shm_idx: fail to find a free user index
2017-05-03 10:03:48 info    kernel: [wifi]: wl1: wlc_txbf_init_exp failed to set shm idx
2017-05-03 10:03:48 info    kernel: [wifi]: 1 wlc_txbf_set_shm_idx: fail to find a free user index
2017-05-03 10:03:48 info    kernel: [wifi]: wl1: wlc_txbf_init_exp failed to set shm idx
2017-05-03 10:03:48 info    kernel: [wifi]: 1 wlc_txbf_set_shm_idx: fail to find a free user index
2017-05-03 10:03:48 info    kernel: [wifi]: wl1: wlc_txbf_init_exp failed to set shm idx
2017-05-03 10:03:48 info    kernel: [wifi]: 1 wlc_txbf_set_shm_idx: fail to find a free user index
2017-05-03 10:03:48 info    kernel: [wifi]: wl1: wlc_txbf_init_exp failed to set shm idx
2017-05-03 10:03:48 info    kernel: [wifi]: 1 wlc_txbf_set_shm_idx: fail to find a free user index
2017-05-03 10:03:48 info    kernel: [wifi]: wl1: wlc_txbf_init_exp failed to set shm idx
2017-05-03 10:03:48 info    kernel: [wifi]: 1 wlc_txbf_set_shm_idx: fail to find a free user index
2017-05-03 10:03:48 info    kernel: [wifi]: wl1: wlc_txbf_init_exp failed to set shm idx
2017-05-03 10:03:48 info    kernel: [wifi]: 1 wlc_txbf_set_shm_idx: fail to find a free user index
2017-05-03 10:03:48 info    kernel: [wifi]: wl1: wlc_txbf_init_exp failed to set shm idx
2017-05-03 10:03:48 info    kernel: [wifi]: wl1: link up (wifi1.1)

When the AP works it's great but this seems to keep happening (normally during skype calls) which is flooding our ticketing system with complaints. This has only started since our 250 rollout.

If anyone has any ideas of what to check that would be great.

Thanks

Oli
Photo of Oli

Oli

  • 10 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 2
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Hi Oli,

Which HiveOS version are you running? Do you know if you have WIPS/WIDS enabled?

You can easily check for this via the CLI:

show run | inc wlan-idp

Thanks,

Nick
Photo of Oli

Oli

  • 10 Posts
  • 0 Reply Likes
Hey Nick,

Apologies regarding the delay.  We're now running version  8.0r1.161337 and i've recently disabled the WIPS settings but we seem to still be getting drops and outages. 

I've had confirmation from our supplier and aerohive that our radio profiles etc look fine so unsure what is causing these outages. The 120's beforehand had no issue so i can only think its the 250's?

Ta
Oli
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Hi Oli,

The next step would be to disable beamforming to see if this mitigates the issue, which txbf refers to in the log that you have included. I am researching how to do this on HiveOS 8.0r1 and will get back to you.

Thanks,

Nick
Photo of Oli

Oli

  • 10 Posts
  • 0 Reply Likes
Thanks Nick,

I looked into some options regarding beamforming on hive manager and it looks disabled but clearly not if those logs suggest that. I look forward to your response.

Ta

Oli
Photo of Kevin Whelan

Kevin Whelan

  • 53 Posts
  • 2 Reply Likes
We have similar issues on 7.1, was hoping the upgrade would finally sort out these 250s but bit reluctant to test now. The client  frustration with these 250s means they keep asking for the 330s to be put back
I have found turning off band steering and letting clients stay on 2.4 helps alot
the client health on 330 was rock solid green but on 250s is very colourful with exactly the same locations, clients and profiles
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Hi all,

For those who are seeing issues such as:

2017-05-03 10:03:48 info kernel: [wifi]: wl1: wlc_txbf_init_exp failed to set shm idx
2017-05-03 10:03:48 info kernel: [wifi]: 1 wlc_txbf_set_shm_idx: fail to find a free user index

Please can you try disabling MU-MIMO and tx-beamforming so that we can A/B test this.

To disable tx-beamforming, you first disable MU-MIMO:

no radio profile <name> mu-mimo enable

By running the following commands, we can verify the presence of this on the radio profiles:

show run | inc mu-mimo

show run | inc "radio profile"

Then, also ensure that no tx-beamforming commands are present in the configuration: 

show run | inc tx-beamforming

Many thanks,

Nick