AP1130 P2P link, bridge port seems to switch to UPLINK

  • 1
  • Question
  • Updated 4 months ago
  • (Edited)
Hi all,

I have the following setup:

Trunk switch port >> AP1130-Main <<Backhaul Mesh Link>> AP1130-Remote

HiveOS = 6.5r7a
MGMT vlan = 199

Main ETH0 = Uplink
Remote ETH0 = Bridge-802.1Q

As long as remote AP is power by a POE adapter, all works fine.

As soon as I connect the remote ETH0 (BridgePort) to a switch trunk port, I loose IP connectivity in the MGMT network and of course also connectivity to hive manager.
No vlan's are passing the link.
The mesh link itself is still up (AP LED's)
 
To me it seems the Bridge port is somehow switching to Uplink port ...

Anybody has an idea ?
Thanks a lot for your support,

Gilles
Photo of Gilles Hoffmann

Gilles Hoffmann

  • 9 Posts
  • 0 Reply Likes
  • frustrated

Posted 5 months ago

  • 1
Photo of Brian Powers

Brian Powers, Champ

  • 396 Posts
  • 92 Reply Likes
The APs by default will expect DHCP from their wired port unless configured otherwise.  You'll need to set the APs eth0 port to either "bridge-access" or "bridge-dot1q" as then it should continue to use the RF link to learn its LAN info.

The command via CLI is - interface eth0 mode bridge-access
Photo of Brian Powers

Brian Powers, Champ

  • 396 Posts
  • 92 Reply Likes
Here's the output on the AP1130.  It seems to work as expected.  And for the life of me I cant see a difference between your pictures/settings and mine.



My AP1130 is running 6.5r4 though.  Let me update that and see if anything changes.

Here are the images you sent that are of my config, maybe you can see a difference...
Device:


AP1130 Template:


Port specific template (setting it to bridge-.1q):


Once I shut down the interface on the switch the AP1130 is plugged into, it linked up to my AP230 (assuming the root portion of the link in my test) as expected.


I'll swap code and see if this still work.
Photo of Brian Powers

Brian Powers, Champ

  • 396 Posts
  • 92 Reply Likes
So after changing the code, it did not revert my settings.  

After factory resetting the AP, and getting in back into HMNG, here are the settings that are to be applied to the eth0 interface:


Link came up over the RF as expected.
Photo of Gilles Hoffmann

Gilles Hoffmann

  • 9 Posts
  • 0 Reply Likes
Thanks, My link works as expected.
E.LU-02.02-AP-1130#show lldp neighbor
LLDP neighbor table: Total number = 1
--------------------------------
Incoming Port: wifi1.1
Chassis ID(mac address): f09c:e9e9:9380
Port ID(interface name): mgt0
Hold time(seconds): 64
System name: E.LU-02.01-AP-1130
System capabilities: bridge, WLAN access point
Enables capabilities: bridge, WLAN access point
Management address:
        IP address: 10.252.60.110
        interface subtype:Interface index, number:10
802.3 Link Aggregation:
        aggregation status: 0x00
                aggregation capability: no
                aggregation status: not enabled
        aggregation port: 0
802.3 Max Frame Size: 1500

If I change the ETH0 to bridge via CLI all works as it should.
Only, HiveManager does not change it from BACKHAUL to BRIDGE.

Same with latest HiveOS 8.2r1

But why, I don-t know. It seem I did the same as you did ...
Photo of Gilles Hoffmann

Gilles Hoffmann

  • 9 Posts
  • 0 Reply Likes
Will try a factory reset as well
Photo of Gilles Hoffmann

Gilles Hoffmann

  • 9 Posts
  • 0 Reply Likes
Dear Brian,

Again thanks for your support. I did some more tests including reset of AP's to factory defaults.

What I actually tried to achieve first is applying different device templates based on different location using the assignment rule option.  

What I found is, if I assign a new location to my AP in Hive Manager NG, it does update the fields in Hive Manager but does not upload all parameters of the new config to the AP, e.g. ETH0 mode and also the radio profile..

If I do the same from a new AP (factory defaults), assign the location before uploading the config the first time and then update the AP, it works.

I guess it is a bug in Hive Manager NG.

Or do you think that is normal behavior of the system? Or is there an option to exclude some parameters to be updated by an upload of a new network policy.