AP 230 reboots from time to time.

  • 2
  • Question
  • Updated 4 years ago
AP 230 reboots from time to time, I have the AP on version 6.2r1, the problem is only with 1 AP, I have another 4 AP's connected to the same switch with no problems. I downloaded the Tech data from the AP and here is the output:

Crash time: 2014-10-22_15-20-22(UTC)
Image Version:       HiveOS 6.2r1 release build1924
Image Build time:    Thu Sep  4 11:08:41 UTC 2014
Image Build cookie:  20140904-3532

Kernel panic - not syncing: Fatal exception in interrupt
====CPU #0 (myself)====begin====
[<c0044104>] (unwind_backtrace+0x0/0xf8) from [<c02c5054>] (panic+0xac/0x22c)
[<c02c5054>] (panic+0xac/0x22c) from [<c004160c>] (die+0x1ac/0x1d8)
[<c004160c>] (die+0x1ac/0x1d8) from [<c00454c4>] (__do_kernel_fault+0x64/0x84)
[<c00454c4>] (__do_kernel_fault+0x64/0x84) from [<c02cad4c>] (do_page_fault+0x1cc/0x278)
[<c02cad4c>] (do_page_fault+0x1cc/0x278) from [<c003d3a4>] (do_DataAbort+0x30/0x9c)
[<c003d3a4>] (do_DataAbort+0x30/0x9c) from [<c02c8e0c>] (__dabt_svc+0x4c/0x60)
Exception stack(0xc03bbb38 to 0xc03bbb80)
bb20:                                                       0000003c 60000193
bb40: ce370600 ffffffff 00000000 0000000f ce32d264 ce01a000 00000000 cf36e860
bb60: 0000001e 00000003 c040744c c03bbb80 bf169f74 bf0d4520 a0000113 ffffffff
[<c02c8e0c>] (__dabt_svc+0x4c/0x60) from [<bf0d4520>] (wlc_prec_enq_head+0x334/0x4c8 [wl])
[<bf0d4520>] (wlc_prec_enq_head+0x334/0x4c8 [wl]) from [<bf0d46c8>] (wlc_prec_enq+0x14/0x1c [wl])
[<bf0d46c8>] (wlc_prec_enq+0x14/0x1c [wl]) from [<bf0f6d88>] (wlc_queue_80211_frag+0x140/0x2b8 [wl])
[<bf0f6d88>] (wlc_queue_80211_frag+0x140/0x2b8 [wl]) from [<bf0f8670>] (wlc_sendmgmt+0x64/0x5d8 [wl])
[<bf0f8670>] (wlc_sendmgmt+0x64/0x5d8 [wl]) from [<bf2aa538>] (wlc_probresp_doiovar+0x430/0x5a4 [wl])
[<bf2aa538>] (wlc_probresp_doiovar+0x430/0x5a4 [wl]) from [<bf2aab74>] (wlc_probresp_recv_process_prbreq+0x270/0x28c [wl])
[<bf2aab74>] (wlc_probresp_recv_process_prbreq+0x270/0x28c [wl]) from [<bf117944>] (wlc_recv+0x16d4/0x2f88 [wl])
[<bf117944>] (wlc_recv+0x16d4/0x2f88 [wl]) from [<bf1ac760>] (wlc_bmac_recv+0x190/0x218 [wl])
[<bf1ac760>] (wlc_bmac_recv+0x190/0x218 [wl]) from [<bf23b068>] (wlc_dpc+0x228/0x868 [wl])
[<bf23b068>] (wlc_dpc+0x228/0x868 [wl]) from [<bf13d6e8>] (wl_dpc+0x4c/0xd4 [wl])
[<bf13d6e8>] (wl_dpc+0x4c/0xd4 [wl]) from [<c0089ca8>] (tasklet_action+0x124/0x184)
[<c0089ca8>] (tasklet_action+0x124/0x184) from [<c0089740>] (__do_softirq+0xe8/0x1e0)
[<c0089740>] (__do_softirq+0xe8/0x1e0) from [<c0089944>] (irq_exit+0x58/0x6c)
[<c0089944>] (irq_exit+0x58/0x6c) from [<c003eb84>] (asm_do_IRQ+0x78/0xd4)
[<c003eb84>] (asm_do_IRQ+0x78/0xd4) from [<c02c8e68>] (__irq_svc+0x48/0xe8)
[<c02c8e68>] (__irq_svc+0x48/0xe8) from [<c003ed34>] (default_idle+0x24/0x28)
[<c003ed34>] (default_idle+0x24/0x28) from [<c003eda8>] (cpu_idle+0x70/0xa4)
[<c003eda8>] (cpu_idle+0x70/0xa4) from [<c0008bf8>] (start_kernel+0x2a0/0x304)
[<c0008bf8>] (start_kernel+0x2a0/0x304) from [<80008084>] (0x80008084)
====CPU #0 (myself)====end====

====other CPUs dump====begin====
====other cpu d
Photo of Javier Espinoza

Javier Espinoza

  • 8 Posts
  • 1 Reply Like

Posted 4 years ago

  • 2
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Javier,
I suggest you contact your reseller or Aerohive technical support, you've already grabbed most  the info they will need to troubleshoot this with and for you. 
Photo of Robert Martin

Robert Martin

  • 4 Posts
  • 0 Reply Likes
We have had the same problem with our AP 230's since the HiveOS upgrade and Hive Manager upgrade to 6.2r1a.  It would occur throughout one of our schools randomly, about a 2-5 per day.  We have tried downgrading the HiveOS to 6.1r6a.1794.  We are still seeing the reboots occur.

Support suggested we try downgrading our Hive Manager to the previous release to see if it clears it up.  Before these recent upgrades, we did not have a problem with the AP 230's rebooting.
Photo of Stan

Stan

  • 3 Posts
  • 0 Reply Likes
Recently updating (less than a week) the AP's firmware to "6.2r1a.1931" seems to have resolved our reboot problem on our AP230s 
Photo of Javier Espinoza

Javier Espinoza

  • 8 Posts
  • 1 Reply Like
Thanks Stan, I'm updating to firmware 6.2r1a.1931, let's see how it works.
Photo of BJ

BJ, Champ

  • 374 Posts
  • 45 Reply Likes
Are either of you running in multicast environments?
Photo of Javier Espinoza

Javier Espinoza

  • 8 Posts
  • 1 Reply Like
Hi BJ, yes we are running in a Multicast Environment.
Photo of Travis Kaufman

Travis Kaufman, Champ

  • 113 Posts
  • 30 Reply Likes
too much mDNS traffic could cause CPU Spikes. Does the Uptime change or does the AP just loose CAPWAP Connection? can you show cpu during a peak time? 
(Edited)
Photo of Javier Espinoza

Javier Espinoza

  • 8 Posts
  • 1 Reply Like
Hi Travis the uptime change, and here are the screenshots of the CPU at the peek time.
Photo of Travis Kaufman

Travis Kaufman, Champ

  • 113 Posts
  • 30 Reply Likes
Ok that looks good.  I know you stated the 4 other AP's are good in the Switch.  
Have you tried Layer 1- Replace the Cable?  If you already have, I would attempt a factory reset on the AP itself, if that is still a NoGo - Request an RMA.