Aerohive AP 230 EtherChannel with Cisco Catalyst 3750

  • 2
  • Question
  • Updated 4 years ago
  • Answered
  • (Edited)
We just installed our new AP 230s with dual Ethernet runs and I'm trying to set up etherchannel trunks on our Cisco Catalyst 3750s.
I ran the following commands to create the etherchannel:

- interface range g1/0/7 - 8
- channel-group 4 mode active
- switchport trunk encapsulation dot1q
- switchport mode trunk

I also changed the setting on the Access Point to use aggregation, but it never establishes the connection. Upon running show etherchannel 4 summary I see:
Group       PortChannel     Protocol      Ports
4                Po4(SD)          G1              Gi1/0/7(s) Gi1/0/8 (I)
Any insight would be extremely appreciated.
Photo of WBTech

WBTech

  • 12 Posts
  • 1 Reply Like

Posted 4 years ago

  • 2
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
I don't know the specific commands on the Cisco switch, but I believe you want to reconfigure it to use old-school etherchannel with no negotiation or dynamic add/drop of links. (I may be wrong; if any other Aerohive employees or one of the champs here contradicts me, trust them over me on this)
Photo of BJ

BJ, Champ

  • 374 Posts
  • 45 Reply Likes
1) Configure port channel...
!

interface Port-channel1

 description ap01

 switchport mode trunk

!

2) Configure interfaces...

!

interface GigabitEthernet1/0/1

 description ap01 etherchannel

 switchport mode trunk

 spanning-tree portfast

 channel-group 2 mode on

!

interface GigabitEthernet1/0/2

 description ap01 etherchannel

 switchport mode trunk

 spanning-tree portfast

 channel-group 2 mode on

!

Best,
BJ



Photo of Jackywong

Jackywong

  • 13 Posts
  • 0 Reply Likes
Support
Photo of BJ

BJ, Champ

  • 374 Posts
  • 45 Reply Likes
Of course test...
sh etherchannel
sh etherchannel port-channel
sh etherchannel 2 (detail, port, port-channel, protocol, summary)

Good luck!

Photo of BJ

BJ, Champ

  • 374 Posts
  • 45 Reply Likes
Oops, just realized my example had the wrong channel-group assigned on the interface...

!

interface Port-channel1

 description ap01

 switchport mode trunk

!

interface GigabitEthernet1/0/1

 description ap01 etherchannel

 switchport mode trunk

 spanning-tree portfast

 channel-group 1 mode on

!

interface GigabitEthernet1/0/2

 description ap01 etherchannel

 switchport mode trunk

 spanning-tree portfast

 channel-group 1 mode on

!

end

My apologies!

Photo of WBTech

WBTech

  • 12 Posts
  • 1 Reply Like
Hey BJ,
Thank you for your response.
I cleared the configs for those interfaces and did what you suggested and I'm still unable to get the etherchannel to work.

sh etherchannel 4 gives me:
Group   Port-channel     Protocol       Ports
4             Po4 (SU)              -              Gi/1/0/7(P) Gi1/0/8 (s)

However, if I disable the etherchannel, both interfaces come up and seem to work fine. I would imagine that would not be an ideal setup as it could potentially cause loops.

On the access point,under Ethernet Setup I have Aggregate Eth0 and Eth1. Should it be something else?
(Edited)
Photo of Andrew MacTaggart

Andrew MacTaggart, Champ

  • 483 Posts
  • 86 Reply Likes
show logging

it should tell what's wrong

channel-group X mode on

has to be "on"

the interfaces should be populated from the port-channel config

int port channel 4
switchport
switchport trunk encap dot1q
switchport mode trunk
switchport non
switchport trunk allowed vlan x,x,x,x,x
no shut

int gig 1/0/1
switchport
switchport trunk encap dot1q
switchport mode trunk
switchport non
switchport trunk allowed vlan x,x,x,x,x
no shut
channel-group 4 mode on

int gig 1/0/2
switchport
switchport trunk encap dot1q
switchport mode trunk
switchport non
switchport trunk allowed vlan x,x,x,x,x
no shut
channel-group 4 mode on

if you want to configure the ports the values must match the port-channel


portfast is for ports that are not trunks

I think you would use portfast trunk mode for trunk links

once again it should match port-channel config

Cheers
A


Photo of BJ

BJ, Champ

  • 374 Posts
  • 45 Reply Likes
Just to be sure I'm not overlooking the obvious, in the AP device configuration, you are aggregating the two interfaces, correct?



Photo of WBTech

WBTech

  • 12 Posts
  • 1 Reply Like
That is correct.
Photo of WBTech

WBTech

  • 12 Posts
  • 1 Reply Like
Also, it wouldn't let me set the interfaces as trunk until I chose the type. I set it to 802.1q encapsulation. Is that correct?
Photo of BJ

BJ, Champ

  • 374 Posts
  • 45 Reply Likes
!
 switchport trunk encapsulation dot1q

 switchport mode trunk

!


Photo of WBTech

WBTech

  • 12 Posts
  • 1 Reply Like
I tried that and my etherchannel still fails to come up. I tried rebooting the AP as well just to ensure the config was applied.
Photo of BJ

BJ, Champ

  • 374 Posts
  • 45 Reply Likes
If the AP isn't in production, try configuring the aggregation, taking it offline, configuring the etherchannel on the switch, then bringing up the AP. Give the etherchannel some time to negotiate.
Once it comes up, note the interface status, the mac table on the interface, and the etherchannel status.  
Photo of BJ

BJ, Champ

  • 374 Posts
  • 45 Reply Likes
Just to be sure, you're not setting your etherchannel to active anymore. Active mode is for LACP, which many of us are hoping AH will support sooner than later. "On" will set you for good, old fashioned Kalpana etherchannel. 
Photo of danmpark

danmpark

  • 2 Posts
  • 0 Reply Likes
Thanks, as soon as I changed my configuration from "active" to "on", this worked.  I have a Cisco 3750 and an AP230.  Used you configuration suggestions above.
Photo of Andrew MacTaggart

Andrew MacTaggart, Champ

  • 483 Posts
  • 86 Reply Likes
would just like to mention that link aggregation with the AP 230 maybe be a waste of an Ethernet port.

only eth0 supports poe(+) so no poe redundancy.

and wave 1 will not exceed 1Gbps speeds.

and an old post about 390

https://community.aerohive.com/aerohive/topics/ap_390_dual_uplink_modes

(Edited)
Photo of WBTech

WBTech

  • 12 Posts
  • 1 Reply Like
Would you suggest we just bypass the aggregation? I saw there was a redundancy mode, but like you said, only one port is POE.
Photo of Andrew MacTaggart

Andrew MacTaggart, Champ

  • 483 Posts
  • 86 Reply Likes
We are laying 2 cables for future use and will most likely agg the AP230, so if you can afford to use 2 ethernet ports and have 2 cable runs, link agg won't hurt, but there will not be any real benefit either.

Were you able to get the port-channel up?

Cheers
A
Photo of WBTech

WBTech

  • 12 Posts
  • 1 Reply Like
I apologize for the delay in my responses, but I was able to get on the line with an Aerohive engineer and he informed me aggregation does not require any changes to be made on the switch as it's handled purely on the AP. All I had to do was remove those port channels, enable aggregation on the APs reboot those units and I have full load balancing aggregation.
(Edited)
Photo of danmpark

danmpark

  • 2 Posts
  • 0 Reply Likes
You got better help from AeroHive than we did,  They told us to buy their switch.  I have my Cisco 3750 and AP230 connected via an EtherChannel following BJ, Champ's advice above.