Aerohive/Airwatch Integration - Cannot get enrollment status

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I can't seem to get Airwatch/Aerohive integration to function correctly. When using the show enrollment status command in HMOL 6.1r1, 6.1r2 or on HiveOS CLI, it gives me "Unknown Error" and "Error: Invalid Parameters" respectively. The practical consequence is that the device is not let out of the walled garden even after it is enrolled into Airwatch.

I've been in contact with both Airwatch and Aerohive support, but no resolution yet.

I've also been able to call the Airwatch API manually using a REST client, so I know that the API URL, API key, and user credentials/permissions are correct. This is based off of Airwatch's API documentation.

Is there anything I'm missing? Has something changed either in HMOL/HiveOS or in Airwatch 6.4/6.5 that might have broken the integration somewhere?

Also, Aerohive only provides documentation in Help for integration with on-prem implementations of Airwatch, so I needed to contact Airwatch to get the proper URLs for SaaS environments. There is a consistent scheme that Airwatch uses in case you guys want to update documentation to assist those that may need to connect to SaaS environments.

Photo of Steven Bateman

Steven Bateman

  • 65 Posts
  • 12 Reply Likes

Posted 4 years ago

  • 1
Photo of Brian Powers

Brian Powers, Champ

  • 391 Posts
  • 91 Reply Likes

I have no idea if the issue you're experiencing relates to this, but I had an issue with a customer a while back that sounds similar.
Photo of Lisa Niles

Lisa Niles

  • 8 Posts
  • 1 Reply Like