Aerohive for Apple Environment- Intermittent Connection issue

  • 2
  • Question
  • Updated 4 years ago
  • Answered

Currently we are running Aerohive POC in a fully Apple Environment. All devices in this organization are Apple (IPhone, Ipad, Apple TV, Air Print and etc). The Aerohive wireless is not stable and connections are intermittently dropped and connect back.  We are using the default High-density profile for both 2.4ghz and 5ghz Radios. The Senior management already started complaining about this as during presentation the Air-play session got cut-off in the middle of presentation. This has been going on from the Day Aerohive APs were installed....What could the issue, do Aerohive APs need special setting to support Apple Environment? I need help and your expert advise would be appreciated. If we don't solve this, we are going to loose the deal.....


Photo of Scorpio_1899

Scorpio_1899

  • 11 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 2
Photo of Andrew MacTaggart

Andrew MacTaggart, Champ

  • 483 Posts
  • 86 Reply Likes
Hi Scorpio_1899

Do you have an existing wireless network?
Is WIPS enabled - would the Aerohive be detected as a Rouge?
if mitigation is in play, the other wireless system may be send deauth messages to clients

Have you tuned the AP to your environment?
I would disable the lower data rates on the b/g radio
and adjust the radio power down on both wifi0 and wifi1

some useful info can be found in

Aerohive High-Density Wi-Fi Design & Configuration Guide

you should check the acsp neighbor info and look at what the AP hears.

this will show you channels and RSSI

compare these values with the Channels chosen by the AP 
you can statically set the Channels if you like.

Since you are using the AppleTV wifi connection see under the active clients what band the AppleTV is connecting. If both the clients support 5Ghz you could try disabling the 2.4Ghz radio to see if the mirroring becomes more stable.

In general I find the user experience better when the AppleTV is using a cable.

if you have the budget

the AP 230s have provided a pleasant environment for our users.

Cheers
A
Photo of Carsten Buchenau

Carsten Buchenau, Champ

  • 356 Posts
  • 117 Reply Likes
Sounds like a matter of interferences caused by not well tuned channels and power output to me...

In addition to Andrew's comments:

Is there a particular reason you have chosen the high density radio profiles from the beginning? How dense is your deployment, and how many clients are typically connecting? In most cases I start with fresh default profiles and only change the 2.4 setting to use channels 1-6-11 (instead of 1-5-9-13 which is the AH default for Europe), and I enable DFS and 40GHz wide channels for 5 GHz.

I  let it run for a day and then have a quick check on how the AH system is automatically assigning channels and power output to the radios. In most cases, I have to say, we still do a manual channel deployment plan, as the automatic process can never be as good. I then let it run again, check for the power and decide for a common value for all radios inside deployment areas.

NOTE: If you see the power output on 2.4 all on 11 (or 14, depending on your HM version and country), you see the minimum that would be used by the automatic assignment process. Edit your 2.4 radio profile and lower the max. output. The default is 20, and thus the minimum used is 14 (which displays as 11 for us now. Don't ask... I still need to talk to Aerohive about that change :-)).

After that, you might want to have a look at the QoS setting, to give some higher priority to Airplay. If you have several SSIDs with different importance, I would start with the "guaranteed airtime" setting first. E.g. 30% for the User profile used by management for Airplay demonstrations....
Photo of Sjoerd de Jong

Sjoerd de Jong, Employee

  • 97 Posts
  • 20 Reply Likes
in addition to your radio profile comments, i would also configure them to channel select in both (2,4 and 5) profiles automatically at night, so when a wi-fi device is installed during the day and it's using one of your AP's channels, the AP is able to change its channel to a 'free' channel overnight.
Photo of Sjoerd de Jong

Sjoerd de Jong, Employee

  • 97 Posts
  • 20 Reply Likes
Also, is the problem only seen in AppleTV sessions? and are you using Bonjour Gateway for this (which is ticked by default). Could this possibly be a Bonjour issue? I have seen this behaviour before when Bonjour Gateway was enabled, and it rebroadcasted the bonjour services that were already in the direct connected network, so the AppleTV services were seen twice by the apple device. This caused some weird behaviour in AppleTV sessions.

If the AppleTV is connected to the same VLAN as the Apple device (iPad, macbook etc), can you test if it's working normally when Bonjour Gateway is disabled?

Best regards,
Sjoerd
Photo of Scorpio_1899

Scorpio_1899

  • 11 Posts
  • 0 Reply Likes

Hi All, Thanks for all the inputs. This environment earlier was running Apple Airports and now we have shutdown Airports and only enabled Aerohive APs. At any point of time, there will be 35 users connected to each AP. As advised I will change the Radio profile to default profiles. The problem is also seen on client connections, sometimes the client connection will cut-off and reconnect. WIPS is disabled. Apple TV and clients are connected within same VLAN. The power and channel selection is set to Auto. I will try to do some fine tuning based on the advise here, once done will monitor and update.. thank you so much for all the suggestions, really appreciated.