aerohive ap and cisco vlan

  • 1
  • Question
  • Updated 2 years ago
I got question for plug the aerohive AP 230 to a cisco switch trunk port.

The cisco trunk port only allowed 11, 16-19. VLAN 101 had network 10.10.4.0/24. I setup my AP's MGT0 vlan to 11, native vlan to 11, and ETH0 Native vlan to 11. and set IP of AP's MGT0 to 10.10.1.5. I can ping myself but cannot ping 10.10.1.1 (this is the gateway).


!
interface GigabitEthernet9/0/12
description Trunk Connection to AeroHive BR200 Router
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 101,613-615,999
switchport mode trunk
no snmp trap link-status

!
[Thu Oct 13 16:29:15 2016] interface Vlan101
[Thu Oct 13 16:29:15 2016]  description Data 101 VLAN
[Thu Oct 13 16:29:15 2016]  ip address 190.10.1.252 255.255.255.0
[Thu Oct 13 16:29:15 2016]  standby 101 ip 190.10.1.254
[Thu Oct 13 16:29:15 2016]  standby 101 priority 150
[Thu Oct 13 16:29:15 2016]  standby 101 preempt
[Thu Oct 13 16:29:15 2016]  standby 101 authentication secret
Photo of bin yu

bin yu

  • 26 Posts
  • 2 Reply Likes

Posted 2 years ago

  • 1
Photo of Rob Burgoyne

Rob Burgoyne

  • 19 Posts
  • 0 Reply Likes
Your switchport config doesn't seem to match what you're saying. The VLANs are (101,613-615,999) on the switch but (11,16-19) on the APs "Looks like you pasted the wrong config as it says BR200 and no AP320"? So check that first. You also don't want to tag your MGMT traffic as VLAN 11 if it's native on the cisco switchport side, just keep mgmt at VLAN1, or change the native to something else on the switch. 
Photo of bin yu

bin yu

  • 26 Posts
  • 2 Reply Likes
Sorry it is the swich port is 11,13-15,999
Photo of bin yu

bin yu

  • 26 Posts
  • 2 Reply Likes
I type wrong message.swich port is 11,13-15,999. And native vlan in switch is set to no ip
Photo of bin yu

bin yu

  • 26 Posts
  • 2 Reply Likes
Did that descption matter. I think this is just a comment. I can change it to any word.

standby 101 authentication secret

What's this line mean
Photo of Bill W.

Bill W.

  • 222 Posts
  • 35 Reply Likes
Try adding "switchport trunk native vlan 11" to the configuration of that port and setting all of the AP VLANs to 1.
Photo of mr bee

mr bee

  • 77 Posts
  • 0 Reply Likes
add switchport trunk native vlan 101. your default gateway is 190.10.1.254 ?
Photo of Luke Harris

Luke Harris

  • 265 Posts
  • 18 Reply Likes
VLAN numbers aside. I would suggest setting your management VLAN as the untagged VLAN on this particular port, and then tag the others. Within my HP deplyoment I also set the PVID to that of the management VLAN and then undo (disable) VLAN 1 (default).