Aerohive and Casper MDM with ElCapitan

  • 1
  • Question
  • Updated 2 years ago
Has anyone had any success with getting MacOS ElCapitan devices to enrol successfully in Casper MDM with Aerohive.

All our other models all show as Mac OS and their MDM enrolment checks out successfully.

We can add an OS Object that detects ElCapitan and displays the client OS as ElCapitan, but when you do an MDM enrolment check, it reports that this OS is not supported by the MDM.

Any ideas?

Any got this working already??
Photo of Daniel Beard

Daniel Beard

  • 3 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Chris

Chris

  • 4 Posts
  • 0 Reply Likes
Hi Daniel,
What version of the JSS are you running?

Chris
Photo of Daniel Beard

Daniel Beard

  • 3 Posts
  • 0 Reply Likes
JSS 9.81, Aerohive 6.6r1
Photo of Daniel Beard

Daniel Beard

  • 3 Posts
  • 0 Reply Likes
From what we can devise, is that under configuration > Advanced Configuration > Security Policies > MDM Configuration... we can only select either iPod/iPhone/iPad and or Mac OS as the OS Objects to associate with Casper Suite...

That's well and good, but those two OS Objects are default built in and cannot be edited or saved.

We can add OS Objects, and have ElCapitan show up in the client OS of the Active Clients list, but there is no way to associate this to the MDM configuration...

That's where we sit...
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Hi Daniel,

Mike Kouri said that he was looking in to getting operating system identification enhanced to correctly identify the newer well known OSes, where they are discriminable, in the upcoming 6.5r3 and 6.6r2 releases of HiveOS. These are due provisionally by the end of this month.

Nick
Photo of Tony Schaps

Tony Schaps

  • 28 Posts
  • 8 Reply Likes
Request for an update to this last comment-- running 6.4r1 and having trouble recognizing OS X 10.11 (El Capitan) Mac clients - usually do not come up as MacOS (sometimes do) but either "unknown" or "Mac OS X 10_11", "Mac OS X 10_11_1", "Mac OS X 10_11_2", or "Mac OS X 10_11_3". Sometimes get classified to the wrong VLAN.  I really don't understand the mechanics, and I don't want to upgrade the OS right now unless I know this would be improved. Please update. Thanks. 
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Is there a particular reason that you do not want to upgrade? You can always upgrade a single AP to 6.5r3 and test. You can easily rollback the image if you want or need to.
(Edited)
Photo of Tony Schaps

Tony Schaps

  • 28 Posts
  • 8 Reply Likes
Not as experienced with Aerohive as I'd like to be, so I am hesitant to update and cause more problems when the system mostly works. In order to update an AP, I need to upgrade the HMOL version, right? Also, I just noticed that there are three different versions of 6.4r1 on the APs-- five AP330's are running 6.4r1a.2103, three AP230's are running 6.4r1e.2116, two others running 6.4r1g.2138. Is that a problem? Also wondering what kind of downtime I can expect if I upgrade the HMOL version. Thanks!