Why was (2) added to airplay name?

  • 3
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
Has anyone else seen this when using a branch router? It's like the original name got held onto or something
Photo of Bradley Chambers

Bradley Chambers, Champ

  • 302 Posts
  • 53 Reply Likes

Posted 5 years ago

  • 3
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Your suspicion is probably correct, but this is not unique to the branch router. Basically, when your client tries to connect to a network and claim a machine name, it has discovered that name already exists so it adds some digits to the end to make its name unique. This can occur when you have the same client attached via both wired and wireless. It can also occur if you only have one network connection but the client goes to sleep and when it wakes up and attempts to claim the name it is told by other devices that cached that name (possibly our product, or your Apple TV, or other Macs on the net) that it is already taken. According to posts on the Apple support forum (see below for one example) this seems to be happening more often with recent releases of OSX.

https://discussions.apple.com/thread/...
Photo of Bradley Chambers

Bradley Chambers, Champ

  • 302 Posts
  • 53 Reply Likes
Thanks Mike!
Photo of Andrew MacTaggart

Andrew MacTaggart, Champ

  • 483 Posts
  • 86 Reply Likes
I have several AppleTVs that are adding these numbers to the end of the names. Is there a way to clear these appended names.

I have removed power to the Apple TV and waited 30 seconds
I have rebooted all the Aerohive APs
I have disabled the bonjour gateway and re-enabled the bonjour gateway to no avail, Something is holding onto the name

in the hive manager it shows up with an increasing number

ATV102-6

the number changes every time the IP address changes.

I dynamically assign the vlan via radius and a statically mapped IP from DHCP, so this shouldn't change again.

I just need to clear out the stale cache

Cheers
A
Photo of Andrew MacTaggart

Andrew MacTaggart, Champ

  • 483 Posts
  • 86 Reply Likes
Figured out a solution

rename the appleTV and reboot
then rename back to the original name and reboot
and the (#s) disapears

Cheers
A
Photo of kevinp

kevinp

  • 1 Post
  • 0 Reply Likes
I had previously tried (most of) this without any luck. Changing the name twice doesn't do it. You HAVE to reboot each time as well.
Photo of Sam Doran

Sam Doran

  • 5 Posts
  • 0 Reply Likes
I've had this happen a few times also, mostly when I've been experimenting with an Apple TV causing it to reboot a lot or disconnect and reconnect from the network. One way to reset things is to disable and reenable bonjour gateway on the BDD. The current BDD is displayed in Monitor > Bonjour Gateway. You can either ssh into the AP that is currently the BDD or open an ssh session in the web browser from the Monitor page under Utilities... > SSH Client, then run the following commands:

no bonjour-gateway enable
bonjour-gateway enable

This will cause a service advertisement interruption on the network but will not disrupt any active sessions. Hope this helps!
(Edited)
Photo of Andrew MacTaggart

Andrew MacTaggart, Champ

  • 483 Posts
  • 86 Reply Likes
using manual addresses on the AppleTvs seems to make this problem go away.
Photo of Sam Doran

Sam Doran

  • 5 Posts
  • 0 Reply Likes
Do you use static reservations in your DHCP server or do you enter them on the Apple TV? I loathe doing data entry with that five way remote. :) I've never tried to do it with Bluetooth with the recent iOS 6.1 update since it allows pairing before a WiFi connection is established. That may be a better experience.
Photo of Andrew MacTaggart

Andrew MacTaggart, Champ

  • 483 Posts
  • 86 Reply Likes
I assign the AppleTVs to specific vlans via radius attributes
I use static reservations with DHCP, but it did not fix the (#) issue
in the HM event logs I would see
Station(xxxx:xxxx:xxxx) ip(10.x.x.55) changed to 10.x.x.39
where .39 was statically assigned via DHCP
too many of these logs

host SomeAppleTV {
        hardware ethernet xx:xx:xx:xx:xx:xx;
        fixed-address 10.x.x.39;
        option subnet-mask 255.255.254.0;
        option routers 10.x.x.1;
        option domain-name "mydomain.com";
        option domain-name-servers 10.x.x.x, 10.x.x.x;
        default-lease-time 259200000;
        max-lease-time 259200000;
}

so for the first deployment of AppleTVs using the wifi, I have statically assigned the addressing with the remote

for our Aerohive deployment this helps with the (#)
but for our Cisco side it does nothing to prevent the (#)

I have another deployment that is using older cisco controllers [cisco stopped writing code for them and they do not have bonjour support] where I use an Aerohive AP as the bonjour gateway. The Apple TVs are using the ethernet interface with manual IPs configured with the remote. These do not display the (#) and are rock stable from the user perspective.

I have another deployment using newer Cisco controllers with the cisco bonjour gateway phase 2 software. I have AppleTVs with static reservations and manual addresses, only the AppleTVs using ethernet manual addressing prevent the (#)

Cheers
A




Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Frankly, if the forthcoming OS X 10.9.3 supports Bluetooth discovery of AppleTVs, I would consider dropping all use of Bonjour gateways.

(Yes, there are other real world use cases of Bonjour and this will not be suitable for all, but in many environments, the only requirement is for AppleTVs and this will solve the discovery issue nicely.)

Photo of Andrew MacTaggart

Andrew MacTaggart, Champ

  • 483 Posts
  • 86 Reply Likes
I suspect legacy stuff will need to be supported.
requirements for i-devices
ios 7.1
appletv os 6.1(version 3?)
Bluetooth 4
and IP connectivity

We attempted this to no avail, but a buddy of mine said he got it to work. I have to check what version ipad he was using at the time.

my poor ipad 2
Bluetooth 2.1 + EDR technology

http://news.softpedia.com/news/Apple-TV-6-1-Has-a-Hidden-Feature-432015.shtml

So I guess it depends on the clients
Maybe the newer devices running 10.9.3 might support it.


Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Thanks! I did not know about the Bluetooth 4.0 dependency, nor that it will therefore not work with an iPad 2 and, presumably, older Macs.
(Edited)
Photo of Christopher Roehl

Christopher Roehl

  • 1 Post
  • 0 Reply Likes
I have a theory, does your networks have a local DNS server?  I have seen this happen most in environments that do not have DNS running on a local server.