802.1x and Android Nougat issues

  • 1
  • Question
  • Updated 1 year ago
Is anyone else having issues with users on Android Nougat being unable to connect to 802.1x network without changing settings?  We have been running the same 802.1x SSID for the past three years.  Now, with the release of Android Nougat, and specifically the Google Pixel phone, users are unable to add the SSID.  The users must change the security settings of the SSID on their phone to either ignore the certificate and connect insecurely or to validate the certificate and manually enter the domain.  Once they make this change, they are able to connect successfully.
Photo of Chad Bryan

Chad Bryan

  • 8 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Hi Chad,

Does the certificate meet the recommended best practice documented here:

https://wiki.geant.org/display/H2eduroam/EAP+Server+Certificate+considerations

Thanks,

Nick
(Edited)
Photo of Kyle Fahrenbach

Kyle Fahrenbach, Sr. Technical Support Engineer

  • 5 Posts
  • 0 Reply Likes
Hello Chad,
I loaded a Nougat based ROM onto my OnePlus2 yesterday and ran into issues connecting to our corporate 802.1X SSID. I was able to work around this by setting the CA certificate, within the SSID set up page, to "do not validate". Not sure if your devices will display the same options as mine. But this is how I was able to get my Nougat phone connected to 802.1x again.


-Kyle
Photo of Chad Bryan

Chad Bryan

  • 8 Posts
  • 0 Reply Likes
Yep, that's the exact same experience that we've had on our end.  Now, I need to find out if that is expected behavior or if there is a configuration change we can make so that users don't have to manually modify the SSID in order to join.