2 out of 8 access points offline after server upgrade to Windows 2012 R2

  • 1
  • Question
  • Updated 2 years ago
Hi,

I have 2 out of 8 access points offline after server upgrade to Windows 2012 R2. I've updated the config in the Hive Manager to point to the new server from a DNS point of view (and it's still pointing to the router). I just can't understand why 2 out of the 8 are offline. I've run a full update and these 2 particular access points are "staging". They can be pinged, so they are alive on the network. All other internet services are working fine and without issue.

Any ideas appreciated.

Thanks in advance.
Photo of Frank Nesci

Frank Nesci

  • 3 Posts
  • 0 Reply Likes
  • confused

Posted 2 years ago

  • 1
Photo of BJ

BJ, Champ

  • 374 Posts
  • 45 Reply Likes
Are you using HMOL or on-prem? Try to ssh into the devices and check capwap status...show capwap client. If it's not pointing to your HM, set the capwap server...capwap client server name x.x.x.x.
Photo of Frank Nesci

Frank Nesci

  • 3 Posts
  • 0 Reply Likes
Hi. Thanks for the reply.

HMOL. I did SSH into both devices, neither was pointing to the capwap server (I got the IP address from the other access points that are working) and tried to set using the capwap client server name. I did update the DNS settings as they were pointing to the old server. The strange part is that I looked at a couple of the APs that are working and they had updated their DNS setting automatically. These two had not and were still pointing to the old DNS server, so I had to change them manually but it doesn't seem to be making a difference at this point.

I ran another show capwap client - it said that is was sending discovery packets to find the server but after a bit they reverted to 0.0.0.0.

Still no connection to the Hive but they are connected to the network. The other 6 APs are all fine.

Confused. Thanking you for your help in advance.
Photo of BJ

BJ, Champ

  • 374 Posts
  • 45 Reply Likes
It looks like you may have already done this, but just to be sure..."dns server-ip x.x.x.x". See if you can ping a dns name, i.e. google.com. If you're able to ping the web, try "no capwap client" then "capwap client server name x.x.x.x" or "capwap client enable" to restart capwap.  
Photo of Frank Nesci

Frank Nesci

  • 3 Posts
  • 0 Reply Likes
I tried all of this and it didn't work. A light bulb went off in my head - I did all of that again and then I did a "reboot" from ssh :) Bingo ! That did it.

Thank you so much for your help, BJ. It's massively appreciated.